YourHead Info

Collage

Collage 2.4

requires: Mac OS X 10.9+ & RapidWeaver 6+

Collage 2.3

requires: Mac OS X 10.7+ & RapidWeaver 5+

Collage 2.2

requires: Mac OS X 10.7+ & RapidWeaver 5+

Collage 2.1

requires: Mac OS X 10.6+ & RapidWeaver 4+

Collage 2.0

requires: Mac OS X 10.6+ & RapidWeaver 4+

*Only publicly released and recommended versions appear in the archive.